Home PageFacebookRSS News Feed
PocketGPS
Web
SatNav,GPS,Navigation
Pocket GPS World - SatNavs | GPS | Speed Cameras: Forums

Pocket GPS World :: View topic - 3590LMT battery / charging problem
 Forum FAQForum FAQ   SearchSearch   UsergroupsUsergroups   ProfileProfile   Log in for private messagesLog in for private messages   Log inLog in 

3590LMT battery / charging problem

 
Post new topic   Reply to topic    Pocket GPS World Forum Index -> Garmin Portable Navigation Devices
View previous topic :: View next topic  
Author Message
fraggle
Occasional Visitor


Joined: Apr 09, 2006
Posts: 14

PostPosted: Tue Sep 04, 2012 8:25 pm    Post subject: 3590LMT battery / charging problem Reply with quote

Hi all,

I bought a new 3590LMT about a month ago.

It's been fine in the car upto about a week ago.

What it is doing is this:-

* Connect it to the car cradle - sometimes the "charge" indicator will come on, most of the time it won't.
* If it does come on, after a random (but normally short) period of time the charge indicator goes out and it says "External power lost, turning off in 15 seconds..." and turns off.

I left it in the cradle last night, connected to a 12V power supply via it's cigarette lighter plug.

Started off showing as charging. A bit later the charge icon went out (12V supply still connected and turned on!)

*But* when I turned off the 12V supply and waited, I could see the battery icon reduced as it used the battery. Then turning the 12V supply back on, the charge indicator did NOT reappear, but the battery icon started creeping back up, as if it was charging but didn't want to let me know about it.

Anyway, i left it in the cradle, turned on, with a 12V supply connected.

In the morning it was dead as a dodo, no battery at all. 12V supply still on, red LED on the charging ciggy plug still on.

Removed from cradle, put back in cradle, it turned on but no charge icon - just a very, very flat battery icon. Put it into standby (quick press of power button), bring it out of standby and the charge icon appears!


I've just tried a hard reset (erase all user data) which doesn't seem to have done anything.

it's just completely unreliable, charges when it feels like it, shows the charge icon when it feels like it (and not always when it appears to be charging).

Plugging the micro USB lead into a computer turns on the USB mode reliably, no problems doing that.

Anyone got any ideas? Anything else I can try before I send it back?


Thanks,
Richard
Back to top
View user's profile Send private message
fruit
Regular Visitor


Joined: Feb 28, 2006
Posts: 100
Location: Brandon, Suffolk, UK

PostPosted: Tue Sep 04, 2012 8:37 pm    Post subject: Reply with quote

Sounds like a faulty lead.

I've read of others having similar problems but can't remember where. A search may find similar cases.
Back to top
View user's profile Send private message Visit poster's website







Posted: Today    Post subject: Pocket GPS Advertising

Back to top
Display posts from previous:   
Post new topic   Reply to topic    Pocket GPS World Forum Index -> Garmin Portable Navigation Devices All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Make a Donation



CamerAlert Database

Click here for the PocketGPSWorld.com Speed Camera Database

Download Speed Camera Database
21.094 (27 Sep 23)



WORLDWIDE SPEED CAMERA SPOTTERS WANTED!

Click here to submit camera positions to the PocketGPSWorld.com Speed Camera Database


12mth Subscriber memberships awarded every week for verified new camera reports!

Submit Speed Camera Locations Now


CamerAlert Apps



iOS QR Code






Android QR Code







Terms & Privacy


GPS Shopping