Home PageFacebookRSS News Feed
PocketGPS
Web
SatNav,GPS,Navigation
Pocket GPS World - SatNavs | GPS | Speed Cameras: Forums

Pocket GPS World :: View topic - Help Please
 Forum FAQForum FAQ   SearchSearch   UsergroupsUsergroups   ProfileProfile   Log in for private messagesLog in for private messages   Log inLog in 

Help Please

 
Post new topic   Reply to topic    Pocket GPS World Forum Index -> MyTomTom / TomTom HOME Desktop
View previous topic :: View next topic  
Author Message
mrgrimsby
Regular Visitor


Joined: Mar 05, 2007
Posts: 147

PostPosted: Tue Mar 31, 2009 7:34 pm    Post subject: Help Please Reply with quote

I have just downloaded totom home 2.6 and it loads up every time i start my pc but I only want it to start when I click on it or connect my tomtom.
In preferences there does not seem to be a way to disable it starting up on widows boot up .....any advice ,as usual, would be very welcome, thank you.
Pete,
Isle Of Wight
Back to top
View user's profile Send private message
richard345
Frequent Visitor


Joined: Mar 09, 2008
Posts: 463
Location: Rainhill, Lancashire Not Merseyside!

PostPosted: Tue Mar 31, 2009 8:07 pm    Post subject: Re: Help Please Reply with quote

mrgrimsby wrote:
I have just downloaded totom home 2.6 and it loads up every time i start my pc but I only want it to start when I click on it or connect my tomtom


Pete, that's exactly what I wanted, but although I work in IT, I don't normally edit the Registry on my own machine - other people's, yes, but not my own.

While looking for something to complete a bad uninstall of a program, I found Revo Uninstaller. It has more tools than just an un-installer and I tried the Auto Start Manager and unchecked the TomTom HOME item and it works now just as I want. OK when I connect my TomTom, it runs though the drives and offers the usual options, but I cancel out of those screens until I am ready to start TT Home.

Might be worth a look?
_________________
Ric - TomTom 520 DEAD - Passed to the great traffic jam in the sky. Now using Maps & Waze on Samsung Galaxy S4 + CamerAlert of course!
Back to top
View user's profile Send private message
Darren
Pocket GPS Staff
Pocket GPS Staff


Joined: 11/07/2002 14:36:40
Posts: 23848
Location: Hampshire, UK

PostPosted: Tue Mar 31, 2009 8:13 pm    Post subject: Reply with quote

In HOME:

Tools | Preferences

Untick Start TomTom HOME automatically when I connect my device to my computer (recommended)

Click 'Done'


_________________
Darren Griffin - Editor
Back to top
View user's profile Send private message Send e-mail Visit poster's website
richard345
Frequent Visitor


Joined: Mar 09, 2008
Posts: 463
Location: Rainhill, Lancashire Not Merseyside!

PostPosted: Tue Mar 31, 2009 8:27 pm    Post subject: Reply with quote

Darren wrote:
In HOME:

Tools | Preferences

Untick Start TomTom HOME automatically when I connect my device to my computer (recommended)

Click 'Done'


Darren, this didn't work for me, regrettably with Win XP Sp3. I thought it woud have sorted it, but no such luck Crying or Very sad
_________________
Ric - TomTom 520 DEAD - Passed to the great traffic jam in the sky. Now using Maps & Waze on Samsung Galaxy S4 + CamerAlert of course!
Back to top
View user's profile Send private message
mrgrimsby
Regular Visitor


Joined: Mar 05, 2007
Posts: 147

PostPosted: Tue Mar 31, 2009 8:38 pm    Post subject: Reply with quote

Thanks for the info, Richard I have ccleaner and it has a start up disable tool for this kind of thing and I forgot all about it until your recommendation .
Problem sorted, thanks again.
Pete.
Back to top
View user's profile Send private message
Darren
Pocket GPS Staff
Pocket GPS Staff


Joined: 11/07/2002 14:36:40
Posts: 23848
Location: Hampshire, UK

PostPosted: Tue Mar 31, 2009 8:42 pm    Post subject: Reply with quote

Strange just tested under XP and mine doesn't auto-launch when the OS is rebooted.
_________________
Darren Griffin - Editor
Back to top
View user's profile Send private message Send e-mail Visit poster's website
mrgrimsby
Regular Visitor


Joined: Mar 05, 2007
Posts: 147

PostPosted: Tue Mar 31, 2009 8:51 pm    Post subject: Reply with quote

Darren mine didn't used to load on start up before I downloaded the latest version but then it did and there was no preference tab that disabled it in tools which bugs me a bit, I have, as I said earlier, managed to use a third party application to stop it loading so all is well again, thanks again.
Pete
Isle Of Wight
Back to top
View user's profile Send private message
Darren
Pocket GPS Staff
Pocket GPS Staff


Joined: 11/07/2002 14:36:40
Posts: 23848
Location: Hampshire, UK

PostPosted: Tue Mar 31, 2009 8:56 pm    Post subject: Reply with quote

Odd, mine was a fresh install done to test when I saw your post. Ho-hum, the joys of Windows. Yet one more reason why I don't.
_________________
Darren Griffin - Editor
Back to top
View user's profile Send private message Send e-mail Visit poster's website
dhn
Frequent Visitor


Joined: Oct 08, 2007
Posts: 2544
Location: Toronto CANADA

PostPosted: Tue Mar 31, 2009 11:13 pm    Post subject: Reply with quote

In the root of the unit is a file called autorun.inf. It's a text file.

The contents look like this:
------------------------------------
[autorun]
action=Run TomTom HOME
#open=InstallTomTomHOME.exe
label=TomTom
icon=tomtom.ico
[DeviceInstall]
#This section is empty; autorun will not install device drivers to your PC.
-----------------------------------------------
Try putting a # in front of the word 'action' using Notepad and see if the problem persists.

No promises ........... Rolling Eyes Shocked
_________________
David
Back to top
View user's profile Send private message
Andy_P
Pocket GPS Moderator
Pocket GPS Moderator


Joined: Jun 04, 2005
Posts: 19991
Location: West and Southwest London

PostPosted: Wed Apr 01, 2009 12:42 am    Post subject: Reply with quote

But the OP want's to stop Home running when Windows starts, before he plugs the TT in, so nothing on the TT itself will help...

To stop it running when Windows starts, you either need a utility like mentioned above or to do a quick registry tweak. That's how I did it.

Although I can't remember exactly what *I* did, here's a very good description of what to do from a previous post:

Quote:
Under Windoze 2000 & XP and similar (I know nothing of Vista, Server 2008 & Windoze 7), you need to go into the Services console. This can be done by going into "Control Panel | Administrative Tools | Services", or from the "Run..." box or Command Prompt using "%SystemRoot%\system32\services.msc /s". ("%SystemRoot%" is a shortcut for what is usually, but not always, "C:\Windows" or "C:\WinNT"; "%Windir%" is another shortcut for pretty much the same thing. On most Windoze installations just typing "services.msc" instead of including the full path and the "/s" will suffice, but the full version caters for weird setups and makes sure you don't see any "Micro$oft Rox!" splash screens.)

You need to be a privileged user to do this, so you may need to run it as Administrator to get access.

Once there, scroll down to "TomTomHOMEService", right-click and choose "Properties". Change "Startup type" from "Automatic" to "Manual", then click "OK" and close the Services console. If you want to stop it as you make the change, rather than have it not start automatically when you next reboot, simply click "Stop" when you're changing its startup type.

Finally, to toggle the state of the service (i.e. start and stop it) without mucking around with opening and closing the Services console, use "net start TomTomHOMEService" and "net stop TomTomHOMEService" in the "Run..." box or at the command prompt.


(Original Post by "Jellyroll" is HERE)



The drawback to any of this though... once you've stopped it running at system startup, I don't think there is a way to get it to run when you plug the TomTom into the USB. I have to run it manually (which suits me anyway!)
Back to top
View user's profile Send private message
philpugh
Lifetime Member


Joined: Dec 28, 2005
Posts: 2003
Location: Antrobus, Cheshire

PostPosted: Thu Apr 02, 2009 2:17 pm    Post subject: Reply with quote

Unless I have missed something about the point of this thread... I get the same as Darren. I'm running XP SP3 and both TTHOME 2.5 and now the newer 2.6 behave as I expect. There is the TT icon in the system tray after booting and when I plug in my 520 (8.302) TTHome starts. I don't see the TTHOME main screen until after the unit is plugged in.
_________________
Phil
Back to top
View user's profile Send private message
richard345
Frequent Visitor


Joined: Mar 09, 2008
Posts: 463
Location: Rainhill, Lancashire Not Merseyside!

PostPosted: Thu Apr 02, 2009 3:44 pm    Post subject: Reply with quote

philpugh wrote:
Unless I have missed something about the point of this thread... I get the same as Darren. I'm running XP SP3 and both TTHOME 2.5 and now the newer 2.6 behave as I expect. There is the TT icon in the system tray after booting and when I plug in my 520 (8.302) TTHome starts. I don't see the TTHOME main screen until after the unit is plugged in.


That's exactly it. The OP does not want the HOME Services running at boot up. When you see the icon in the System Tray, that's just what has happened.

By using one of the methods above, the intention is to prevent the service starting when it is not required, thus releasing resources on the machine.

I don't like odd programs having control, by stealth, of my laptop,!
_________________
Ric - TomTom 520 DEAD - Passed to the great traffic jam in the sky. Now using Maps & Waze on Samsung Galaxy S4 + CamerAlert of course!
Back to top
View user's profile Send private message
MaFt
Pocket GPS Staff
Pocket GPS Staff


Joined: Aug 31, 2005
Posts: 14964
Location: Bradford, West Yorkshire

PostPosted: Thu Apr 02, 2009 7:27 pm    Post subject: Reply with quote

you can try:

START
RUN
type: msconfig
under 'Startup' tab untick TomTom home


next time your pc restarts it will come up with a window saying something like 'your computer is running in a diagnostics mode' or similar then just tick the 'dont show this again' and you'll not be pestered again.

if needs must, you can revert back to how it was by simply runnning msconfig again and re-ticking tomtom home

MaFt
Back to top
View user's profile Send private message Visit poster's website
Andy_P
Pocket GPS Moderator
Pocket GPS Moderator


Joined: Jun 04, 2005
Posts: 19991
Location: West and Southwest London

PostPosted: Thu Apr 02, 2009 11:00 pm    Post subject: Reply with quote

MaFt wrote:
you can try:

START
RUN
type: msconfig
under 'Startup' tab untick TomTom home



That would be a great method if 'Home' appeared in the "startup" list.... (but it doesn't)
There's one TomTom entry in the "services" tab, but I'm pretty sure I tried defeating that too.
TT seem to have got more and more devious about how Home gets started, and that's why it needed more devious methods to stop it!
Back to top
View user's profile Send private message







Posted: Today    Post subject: Pocket GPS Advertising

Back to top
Display posts from previous:   
Post new topic   Reply to topic    Pocket GPS World Forum Index -> MyTomTom / TomTom HOME Desktop All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Make a Donation



CamerAlert Database

Click here for the PocketGPSWorld.com Speed Camera Database

Download Speed Camera Database
21.055 (31 May 23)



WORLDWIDE SPEED CAMERA SPOTTERS WANTED!

Click here to submit camera positions to the PocketGPSWorld.com Speed Camera Database


12mth Subscriber memberships awarded every week for verified new camera reports!

Submit Speed Camera Locations Now


CamerAlert Apps



iOS QR Code






Android QR Code







Terms & Privacy


GPS Shopping