Home PageFacebookRSS News Feed
PocketGPS
Web
Read the current newsletter! Weekly
Newsletter
SatNav,GPS,Navigation
Get Speed Camera Warnings For SatNavs Get Speed Camera Warnings For Android Get Speed Camera Warnings For iPhone
Pocket GPS World - SatNavs | GPS | Speed Cameras: Forums

Pocket GPS World :: View topic - iGo 8.3 skins and problems
 Forum FAQForum FAQ   SearchSearch   UsergroupsUsergroups   ProfileProfile   Log in for private messagesLog in for private messages   Log inLog in 

iGo 8.3 skins and problems

 
Post new topic   Reply to topic    Pocket GPS World Forum Index -> NavNGo iGO
View previous topic :: View next topic  
Author Message
malc_b
Occasional Visitor


Joined: Jun 11, 2009
Posts: 4

PostPosted: Mon Jun 26, 2017 10:53 am    Post subject: iGo 8.3 skins and problems Reply with quote

I've got a new sat nav for my birthday to replacing my old one. I choose a cheap 5in winCE model as I new I could always fall back to running the 8.3.2 iGo on my old sat nav. I like iGo and the fact I can skin it.

My new sat nav came with iGo 8.3.4 and a lot of skins, Fab1.2, Riks, etc. most of which just crash with out of memory /layer expected. Anyone know what causes this error and is there a fix?

Anyone know of a source of 8.3 skins? Most links seem old and no longer work. I have some skins but this sat nav has more screen area so can afford to have larger items. I like GJ6 skin except I'd like the bottom bar a touch bigger and the compass is not nice (Or is there a good guide on how to edit skins?).
Back to top
View user's profile Send private message
M8TJT
The Other Tired Old Man
The Other Tired Old Man


Joined: Apr 04, 2006
Posts: 8818
Location: Bexhill, East Sussex, UK

PostPosted: Mon Jun 26, 2017 6:08 pm    Post subject: Re: iGo 8.3 skins and problems Reply with quote

malc_b wrote:
My new sat nav came with iGo 8.3.4 and a lot of skins, Fab1.2, Riks, etc. most of which just crash with out of memory /layer expected. Anyone know what causes this error and is there a fix?
That error is caused by some idiot just loading a bunch of skins on it when they don't know what they are doing and don't put all the stuff on it. This can happen if someone had edited the data.zip file and put a layer in it that is required by his skin, but that data.zip has not been provided. Debugging will tell you the name of the missing layer. But where to get it from ??????
A layer is pretty much anything on the screen such a speed camera alerts etc.
Quote:
Anyone know of a source of 8.3 skins? Most links seem old and no longer work.
That's about par for th course with iGo8 these days
Quote:
I have some skins but this sat nav has more screen area so can afford to have larger items. I like GJ6 skin except I'd like the bottom bar a touch bigger and the compass is not nice (Or is there a good guide on how to edit skins?).
I couldn't find one. It takes quite a bit of time to learn the 'language' and syntax, but it is possible to re-scale an existing skin to a higher re4s screen if you know what you are doing. But it ain't easy.
Back to top
View user's profile Send private message
malc_b
Occasional Visitor


Joined: Jun 11, 2009
Posts: 4

PostPosted: Mon Jun 26, 2017 6:43 pm    Post subject: Reply with quote

BTW the the error is (greater than)/layer(less than) expected and out memory, not either/or as it could be read. I had a poke about but I could find a missing (greater than)/layer(less than).

I've tried a few data.zip and branding.zip. My branding.zip from my old sat nav has icons in it which my poi need. I guess I have saved a poi and given it an icon which was in branding.zip. The new iGo just seems to have the start up screens in branding which would seem more sensible.
Back to top
View user's profile Send private message
MaFt
Pocket GPS Staff
Pocket GPS Staff


Joined: Aug 31, 2005
Posts: 13627
Location: Bradford, West Yorkshire

PostPosted: Tue Jun 27, 2017 12:51 pm    Post subject: Reply with quote

malc_b wrote:
BTW the the error is (greater than)/layer(less than) expected and out memory, not either/or as it could be read. I had a poke about but I could find a missing (greater than)/layer(less than).

I've tried a few data.zip and branding.zip. My branding.zip from my old sat nav has icons in it which my poi need. I guess I have saved a poi and given it an icon which was in branding.zip. The new iGo just seems to have the start up screens in branding which would seem more sensible.


I think you have 'greater than' and 'less than' the wrong way around.

If you have then that would be standard markup - the gt/lt surrounding the tag and the / saying it's the end of the tag. I.e. the error is saying that there's a start tag for {layer} but not the ending tag of {/layer}

Are there any opening {layer} tags? If not then what if you simply add an empty layer - {layer}{/layer} ?

I have no idea how they do their skins so I'm just clutching at straws really.
_________________
MaFt®
Back to top
View user's profile Send private message Visit poster's website
malc_b
Occasional Visitor


Joined: Jun 11, 2009
Posts: 4

PostPosted: Tue Jun 27, 2017 4:29 pm    Post subject: Reply with quote

DUH, yes wrong way round is gt and lt.

I've done a search in files for layer and then looked down the files but I can't spot a missing closing tag. I think the error is wrong though and not actually tell me the real problem. This sat nav came with 6 skins which all fail with the same error. It would seem odd if all 6 had missed a closing layer tag so I think it is something else missing, or they are skins for a different iGo or later version.
Back to top
View user's profile Send private message
M8TJT
The Other Tired Old Man
The Other Tired Old Man


Joined: Apr 04, 2006
Posts: 8818
Location: Bexhill, East Sussex, UK

PostPosted: Tue Jun 27, 2017 4:35 pm    Post subject: Reply with quote

Does that mean that you can't get it working at all because of the errors?
Back to top
View user's profile Send private message
malc_b
Occasional Visitor


Joined: Jun 11, 2009
Posts: 4

PostPosted: Tue Jun 27, 2017 4:56 pm    Post subject: Reply with quote

The "bad" skins stop iGo from working, it crashes. iGo works ok with "good" skins and default skin.

Actually I found that 8.3.4 had a problem with a specific post code which worked ok in my 8.3.2. I tried maps and sys.txt and eventually tried swapping juts the iGo exe. 8.3.2 worked (as did it 8.3.5 I tried) but put 8.3.4 exe back and with this post code it crashed. It was a post code that didn't come up with a region as most do. Other post codes worked ok with 8.3.4. I think 8.3.4 has a memory leak with certain post codes that wasn't in 8.3.2 and that they fixed in 8.3.5
Back to top
View user's profile Send private message







Posted: Today    Post subject: Pocket GPS Advertising

Back to top
Display posts from previous:   
Post new topic   Reply to topic    Pocket GPS World Forum Index -> NavNGo iGO All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB 2.0.11 © 2001 phpBB Group
phpBB port v2.1 based on Tom Nitzschner's phpbb2.0.6 upgraded to phpBB 2.0.4 standalone was developed and tested by:
ArtificialIntel, ChatServ, mikem,
sixonetonoffun and Paul Laudanski (aka Zhen-Xjell).

Version 2.1 by Nuke Cops © 2003 http://www.nukecops.com

Make a Donation



CamerAlert Database

Click here for the PocketGPSWorld.com Speed Camera Database

Download Speed Camera Database
15.122 (13 Dec 17)



WORLDWIDE SPEED CAMERA SPOTTERS WANTED!

Click here to submit camera positions to the PocketGPSWorld.com Speed Camera Database


12mth Subscriber memberships awarded every week for verified new camera reports!

Submit Speed Camera Locations Now


CamerAlert Apps



iOS QR Code






Android QR Code







© Terms & Privacy


GPS Shopping